图算法10之1019

1 题目编号:1019

2 题目内容:

Problem Description
<b>Background </b><br>Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. <br><br><b>Problem </b><br>Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.<br>
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!

3 解题思路形成过程:首先所有昆虫应该属于两个集合,但是仅从每组输入,我们并不知道昆虫属于哪个集合,因此只能给他们各自一个集合,如果A B然后又有A C我们可以判断B与C属于一个集合,如果我们发现两个属于同一个集合,或者两个的对立集合是同一个集合,则两者同性,发生bug,不发生bug的两个发生关系,那么应该合并a和b的对立集合,b和a的对立集合

4 代码:

#include <iostream>  
#include <stdio.h>  
#include <map>  
using namespace std;  
  
const int M=2005;  
map<int,int> uf;        //昆虫所在集合  
map<int,int> op;        //昆虫对立性别所在集合  
  
int find(int i)  
{  
    if(i==uf[i])  
        return i;  
    return uf[i]=find(uf[i]);  
}  
  
void merge(int i,int j)  
{  
    int t1=find(i);  
    int t2=find(j);  
    if(t1==t2)  
        return;  
    uf[t2]=t1;  
    merge(op[t2],op[t1]);   //同时要合并对立集合  
}  
  
int main()  
{  
    //freopen("1.in","r",stdin);  
    int n,m;  
    int t;  
    int co=1;  
    int i1,i2;  
    int f;  
    scanf("%d",&t);  
    while(t--)  
    {  
        f=0;  
        uf.clear();  
        op.clear();  
        scanf("%d%d",&n,&m);  
  
        for(int i=0;i<m;i++)  
        {  
            scanf("%d%d",&i1,&i2);  
            if(f)  
                continue;  
            if(!uf[i1])  
                uf[i1]=i1;  
            if(!uf[i2])  
                uf[i2]=i2;  
            if(find(i1)==find(i2))  
                f=1;  
            else  
            {  
                int par1=find(i1);  
                int par2=find(i2);  
                if(!op[par1])  
                    op[par1]=par2;  
                if(!op[par2])  
                    op[par2]=par1;  
                if(find(op[par1])==find(op[par2]))  
                    f=1;  
                else  
                {  
                    merge(op[par1],i2);  
                    merge(op[par2],i1);  
                }  
            }  
        }  
        printf("Scenario #%d:\n",co++);  
        if(f)  
            printf("Suspicious bugs found!\n\n");  
        else  
            printf("No suspicious bugs found!\n\n");  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值