搜索算法5之1003



1 题目编号:1003

2 题目内容:

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>
 

Sample Output
  
  
25.1327<br>3.1416<br>50.2655<br>
 

Source
NWERC2006
 

3 解题思路形成过程:要办生日party,有n个蛋糕,有f个朋友,,所以f+1个人分,问每个人分到的最大体积的蛋糕多大,每个人所分蛋糕必须在同一个蛋糕上。很简单,此题用二分法即可求出最优解。

4 感想:最近做的几个题都用到了二分法,我认为凡是给定一个范围,要求找到一个值,且查找的范围中的数是线性排列的,即被缩小的范围的那一半中的数一定不符合条件时,都可以用二分法。 

5 代码:

#include<iostream>
#include <stdio.h>  
#include <cmath>  
#include <algorithm>  
#define PI  acos(-1.0) 
using namespace std;
double s[10005];
double find(int n, int f, double r){
double l = 0, ans;
int count, max;
while (1){
if (n > f + 1)
max = f + 1;
else
max = n;
count = 0;
ans = (l + r) / 2;
for (int i = 0; i < max; i++)
count += (int)(s[i] / ans);
if (r - l <= 1e-6)   return ans;
if (count >= f + 1)
l = ans;
else
r = ans;
}
}
bool cmp(double a, double b){
return a > b;
}
int main(){
int n, f, i, t, r;
double Rmax=0.0;
cin >> t;
while (t--){
r = 0;
cin >> n >> f;
for (i = 0; i < n; i++){
cin >> r;
s[i] = PI * r * r;
Rmax = Rmax >= s[i] ? Rmax : s[i];
}
sort(s, s + n, cmp);
printf("%.4lf\n", find(n, f, Rmax));
}
return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值