4 Values whose Sum is 0 --CSU-ACM2017暑假集训2-二分搜索



The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).



题目意思是只要4个数只要来自4个数组的不同位置且相加为0就算一组,两个4元序列完全相等也算新的一组。

另,注释的地方跪了好多遍。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;


int main()
{
    long long n;
    while(~scanf("%lld",&n))
    {
        vector<long long> a,b,c,d,sum1,sum2;
        for(long long i=1;i<=n;i++)
        {
            long long x1,x2,x3,x4;
            scanf("%lld%lld%lld%lld",&x1,&x2,&x3,&x4);
            a.push_back(x1);
            b.push_back(x2);
            c.push_back(x3);
            d.push_back(x4);
        }

        for(long long i=0;i<n;i++)
            for(long long j=0;j<n;j++)
            sum1.push_back(a[i]+b[j]);

        for(long long i=0;i<n;i++)
            for(long long j=0;j<n;j++)
            sum2.push_back(c[i]+d[j]);

        sort(sum1.begin(),sum1.end());
        sort(sum2.begin(),sum2.end());
        long long cnt=0;
        for(long long i=0;i<n*n;i++)//之前写成i=1;i<=n*n;而WA了无数遍。
        {
            long long left=lower_bound(sum2.begin(),sum2.end(),0-sum1[i])-sum2.begin();
            long long right=upper_bound(sum2.begin(),sum2.end(),0-sum1[i])-sum2.begin();
            cnt+=(long long)(right-left);
    //        if(right-left!=0)cout<<sum1[i]<<endl;
        }
        cout<<cnt<<endl;
    }


}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值