PTA甲 1105. Spiral Matrix (25)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrixis filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
这道题题目并不是很难但是在调节的过程中比较麻烦。
ac代码

#include <iostream>

#include <cstdio>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;


bool cmp(int a,int b){
    return a>b;
}


int a[10005];
int matrix[205][205];


int main()
{
int n,r,c,N,M,i,j;
scanf("%d",&n);


for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}


sort(a,a+n,cmp);


int min=100000;


for(c=1;c<=n;c++)
{
for (r=1;r<=c;r++)
{
if(c*r==n)
{
if (c-r<min)
{
min=c-r;
N=r;
M=c;
}
}
}
}


memset(matrix,-1,sizeof(matrix));


int f=0,n0=0,m0=0;


for(i=0;i<n;i++)
{
matrix[m0][n0]=a[i];
if(f==0)
       {
if(n0+1<N&&matrix[m0][n0+1]==-1)
{
n0++;
}
else
{
m0++;
f=1;
}
}
else if(f==1)
{
if(m0+1<M&&matrix[m0+1][n0]==-1)
{
m0++;
}
else
{
n0--;
f=2;
}
}
else if(f==2)
{
if (n0>0&&matrix[m0][n0-1]==-1)
{
n0--;
}
else
{
m0--;
f=3;
}
}
else
{
if(m0>0&&matrix[m0-1][n0]==-1)
{
m0--;
}
else
{
n0++;
f=0;
}
}


}
for(i=0;i<M;i++)
{


for(j=0;j<N-1;j++)
{
printf("%d ",matrix[i][j]);
}
printf("%d",matrix[i][N-1]);


printf("\n");
}






return 0;






}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值