PTA甲 1101. Quick Sort (25)

题目描述

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:
    5
    1 3 2 4 5
    
    Sample Output:
    3
    1 4 5
      此题虽然叫快排,但是跟快排的的关系不大,主要利用的快排的性质。快速排序有一个特点,就是在排序过程中,我们会从序列找一个,它前面的都小于它,它后面的都大于它的一个pivot。所以只要设置两个数组maxnum和minnum,分别表示i之前的最大值和i之后的最小值,找出num[i]<=minnum[i]&&num[i]>=maxnum[i]的情况就可以。

    ac代码

    #include <cstdio>
    #include <algorithm>
    #define INF 0x3f3f3f3f
    using namespace std;
    const int MAX = 100000+5;
    int num[MAX];
    int maxnum[MAX];
    int minnum[MAX];
    int main()
    {
    int n,i,j,cnt=0;


    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
    scanf("%d",&num[i]);
    }
    num[n+1]=INF;
    minnum[n+1]=INF;
    for(i=n;i>=1;i--)
    minnum[i]=min(minnum[i+1],num[i+1]);
    for(i=1;i<=n;i++)
    maxnum[i]=max(maxnum[i-1],num[i-1]);
        int res[MAX];


    for(i=1;i<=n;i++)
    {
    if(num[i]>=maxnum[i]&&num[i]<=minnum[i])
    {
    cnt++;
    res[cnt]=num[i];
    }
    }
    printf("%d\n",cnt);
    if(cnt>=1){
    printf("%d",res[1]);
    for(i=2;i<=cnt;i++)
    printf(" %d",res[i]);
    }
    printf("\n");
    return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值