Rightmost Digit

 

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66883    Accepted Submission(s): 25091


 

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

 

Output

For each test case, you should output the rightmost digit of N^N.

 

 

Sample Input

 

2

3

4

 

 

Sample Output

 

7

6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
//运用快速幂求解,否则会出现超时现象;
   
long long shu(long long  n) {          //注意long long 型变量
	long long  result=1,b=n,a=n;
	while(b!=0) {
		if(b%2!=0)
			result=result*a%10;
		a=a*a%10;
		b=b>>1;
	}
	return result;
}
int main() {
	long long t,n;
	cin>>t;
	while(t--) {
		cin>>n;
		printf("%lld\n",shu(n));
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值