POJ2676 Sudoku(dfs)

Sudoku
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16161 Accepted: 7894 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127



数独游戏,0代表空格,让你填入数字,使得每行每列都是1-9。


    通过i,j,与网格关系可得出关系式:k = 3 * ((i - 1) / 3) + (j - 1) / 3 + 1,用来标记网格vis。每组数据从(1, 1)开始dfs,dfs内首先判断当前数字是0还是非0,若为非0则判断是否已经到了第九列,是的话就dfs下一行,否则dfs下一列(也就是遍历所有)。若当前数字为0则从1到9扫一遍,若扫到当前行当前列且格的第i个未访问,就标记,而后再判断是否是第9列,最后判断是否符合题意,不符合则当前网格修改回去。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 10;
int map[MAXN][MAXN];
bool row[MAXN][MAXN], col[MAXN][MAXN], vis[MAXN][MAXN];
bool dfs(int x, int y)
{
	if(x == 10) return true;
	bool flag = false;
	if(map[x][y]) {
		if(y == 9) flag = dfs(x + 1, 1);
		else flag = dfs(x, y + 1);
		if(flag) return true;
		else return false;
	}
	else {
		int k = 3 * ((x - 1) / 3) + (y - 1) / 3 + 1;
		for(int i = 1; i <= 9; ++i)
				if(!row[x][i] && !col[y][i] && !vis[k][i]) {
					map[x][y] = i;
					row[x][i] = true;
					col[y][i] = true;
					vis[k][i] = true;
					if(y == 9) flag = dfs(x + 1, 1);
					else flag = dfs(x, y + 1);
					if(!flag) {
						map[x][y] = 0;
						row[x][i] = false;
						col[y][i] = false;
						vis[k][i] = false;
					}
					else return true;
				}
	}
	return false;
}
int main(int argc, char const *argv[])
{
	int t;
	cin >> t;
	while(t--) {
		memset(row, false, sizeof(row));
		memset(col, false, sizeof(col));
		memset(vis, false, sizeof(vis));
		char s[MAXN][MAXN];
		for(int i = 1; i <= 9; ++i)
			for(int j = 1; j <= 9; ++j) {
				cin >> s[i][j];
				map[i][j] = s[i][j] - '0';
				if(map[i][j]) {
					int k = 3 * ((i - 1) / 3) + (j - 1) / 3 + 1;
					row[i][map[i][j]] = true;
					col[j][map[i][j]] = true;
					vis[k][map[i][j]] = true;
				}
			}
		dfs(1, 1);
		for(int i = 1; i <= 9; ++i) {
			for(int j = 1; j <= 9; ++j)
				cout << map[i][j];
			cout << endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值