uva120--模拟

120 - Stacks of Flapjacks

Time limit: 3.000 seconds


 Stacks of Flapjacks 

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0
给一个类似栈的结构,每次操作可以将i,j之间的数翻转,求如何翻转使其按升序排列。
#include <iostream>
#include <cstdio>
#include <string.h>
#include <map>
#include <stack>
#include <queue>
#include <algorithm>
#include <math.h>
#include <vector>
#include <set>
#include <iomanip>
#define from(i,a,n)   for(int i=a;i<n;i++)
#define refrom(i,n,a) for(int i=n;i>=a;i--)
#define EPS 1e-10
#define mod 1000000007
using namespace std;

const double INF=0x3f3f3f3f;
const int MAX =31;
int pancake[MAX],pancake1[MAX],record[MAX];
char cake[MAX];

void inverse(int f,int t)
{
		int temp;
		while(f<=t)
		{
			temp=pancake[f];
			pancake[f]=pancake[t];
			pancake[t]=temp;
			f++;
			t--;
		}
		return ;
}

int main()
{
    while(gets(cake))
	{
		int cnt=0,pos=0,len,factor=1,num=0;
		len=strlen(cake);
		from(i,0,len)
		{
			if(cake[i]!=' ')
			{
				num=num*factor+cake[i]-'0';
				factor*=10;
			}
			else{
				pancake[cnt]=num;
				pancake1[cnt++]=num;
				num=0;
				factor=1;
			}
			if(i==len-1)
			{
				pancake[cnt]=num;
				pancake1[cnt++]=num;
				num=0;
				factor=1;
			}
		}//将字符型数据转化为整型
		sort(pancake1,pancake1+cnt);//该数组保存的是排好序应该出现的序列
		int x=cnt-1,flag=1;
		cout<<cake<<endl;
		refrom(i,cnt-1,0)
		{
				if(flag)
				{refrom(j,x,0)
				if(pancake[j]==pancake1[x])
				{
					inverse(0,j);//讲找到的应该在x的数先翻转到栈的顶部
					record[pos++]=j;//记下操作的位置
					inverse(0,x);//再将该数从顶部放到x这样就保证了位于x的数是能够放下的最大数
					record[pos++]=x;//记录操作
					x--;
					break;
				}
				}
			from(i,0,cnt)//判断是否已经有序,若有序,则下面的操作不用再进行
			{
				if(pancake[i]!=pancake1[i]) {flag=1;break;}
				else flag=0;
			}
		}

		from(i,0,pos)
		cout<<cnt-record[i]<<" ";//输出数据,因为栈的实际位置与我们读入数据相反,所以输出结果也应反过来
		cout<<"0"<<endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值