Stacks of Flapjacks



Stacks of Flapjacks

Submit Status

Description

Download as PDF

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

大意:

模拟现实翻煎饼,将给出的一组煎饼变化成从小到大排序,最后一个给出的位置记为1,之前的依次加一

要点:

翻煎饼的时候只能将所选位置的煎饼之上的序号颠倒

所以策略是每次找到一个最大的煎饼翻到最上面,然后最从最下层再将整个煎饼组颠倒过来,处理完1个

煎饼组总个数-1,再在剩下的煎饼组里找最大的,重复上面步骤(如果最大的煎饼在最底层,则跳过寻找直接-1)

代码:

#include <iostream>
#include <string>
using namespace std;

int cur[35], t[35];
int allnum;

void print(int n)
{
	int max = cur[0];
	int flag = 0;
	for (int i = 0; i < n; i++){
		if (max < cur[i]){
			max = cur[i];
			flag = i;
		}
	}

	if (flag == n - 1)
		return;

	if (flag != 0){
		cout << allnum - flag << " ";
		int j = 0;
		for (int i = flag; i >= 0; i--, j++)
			t[j] = cur[i];
		for (int i = flag + 1; i < allnum; i++, j++)
			t[j] = cur[i];
		for (int i = 0; i < allnum; i++)
			cur[i] = t[i];
	}
	
	for (int i = 0; i < n; i++)
		cur[i] = t[n - i - 1];

	for (int i = 0; i < allnum; i++)
		t[i] = cur[i];

	cout << allnum - (n - 1) << " ";
}

int main()
{
	string str;
	while (getline(cin, str)){
		allnum = 0;
		for (int i = 0; i < str.length(); i++){
			if (str[i] == ' '){
				allnum++;
				continue;
			}
			cur[allnum] = cur[allnum] * 10 + str[i] - '0';
			t[allnum] = cur[allnum];
		}
		allnum++;
		for (int i = 0; i < allnum; i++){
			if (i != allnum - 1)
				cout << cur[i] << " ";
			else
				cout << cur[i] << endl;
		}
		for (int i = allnum; i >= 2; i--)
			print(i);
		cout << "0" << endl;
		for (int i = 0; i < allnum; i++)
			cur[i] = 0;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值