http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=10
skiing
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
5
-
描述
-
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
-
输入
-
第一行表示有几组测试数据,输入的第二行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
后面是下一组数据;
输出
- 输出最长区域的长度。 样例输入
-
1 5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
样例输出
-
25
-
第一行表示有几组测试数据,输入的第二行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
设dp[i][j]表示从点(i,j)开始的最长递减序列的长度,初始化为dp=1;起点是自己,终点是自己
现在考虑另一个问题,什么时候dp[i][j]能够被更新?答案肯定是周围有出现比他小的,并且是所有比他小的都可以更新他,比他大的都不能更新他,那么只需要根据权值从小到大枚举他即可。
//dp500-11
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#define LL long long
using namespace std;
const int maxn=1<<30;
const int SIZE=1e2+10;
const int step[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int r,c;
struct node{
int i,j,x;
bool operator<(const node &other)const{
return x<other.x;
}
}a[SIZE*SIZE];
int cmap[SIZE][SIZE],dp[SIZE][SIZE];
bool in(int x,int y){
return x>=0&&x<r&&y>=0&&y<c;
}
int main()
{
int T;
scanf("%d",&T);
for(int cas=1;cas<=T;cas++){
scanf("%d%d",&r,&c);
int cnt=0;
for(int i=0;i<r;i++){
for(int j=0;j<c;j++){
scanf("%d",&cmap[i][j]);
a[cnt].i=i;
a[cnt].j=j;
a[cnt].x=cmap[i][j];
cnt++;
dp[i][j]=1;
}
}
sort(a,a+cnt);
int ans=1;
for(int i=0;i<cnt;i++){
int Max=0;
for(int j=0;j<4;j++){
int x=a[i].i+step[j][0];
int y=a[i].j+step[j][1];
if(in(x,y)&&cmap[a[i].i][a[i].j]>cmap[x][y]){
if(Max<dp[x][y])Max=dp[x][y];
}
}
dp[a[i].i][a[i].j]=Max+1;
if(ans<Max+1)ans=Max+1;
}
printf("%d\n",ans);
}
return 0;
}