http://acm.hdu.edu.cn/showproblem.php?pid=1171
Big Event in HDU
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33877 Accepted Submission(s): 11777
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output
20 10 40 40
多重背包,这一题数据有点坑,有除了-1以外的负数。
设dp[i][j]表示前i种物品放入大小为j的背包所获得的最大价值。
题意:有n种物品,每种物品价值为wi,体积为ci,每种有mi个,问怎么放在总体积不超过sum/2的情况下使得背包的价值最大,本题中的价值等于体积。这样就是一个多重背包的问题了,一个很重要的式子sum>=sum/2;
一开始wa无数,搞得代码乱七八糟的
//dp500-7
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1<<30;
const int SIZE=1e2+10;
int m[SIZE],v[SIZE];
int dp[130000];
void Complete_pack(int c,int w){
for(int i=c;i<=w;i++)
dp[i]=max(dp[i],dp[i-c]+c);
}
void Zero_one_pack(int c,int w){
for(int i=w;i>=c;i--){
dp[i]=max(dp[i],dp[i-c]+c);
}
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
if(n<0)break;
int sum=0;
for(int i=1;i<=n;i++){
scanf("%d%d",&v[i],&m[i]);
sum+=v[i]*m[i];
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++){
if(v[i]*m[i]>=sum/2){
Complete_pack(v[i],sum/2);
}
else{
int k=1;
while(k<m[i]){
Zero_one_pack(k*v[i],sum/2);
m[i]-=k;
k<<=1;
}
Zero_one_pack(m[i]*v[i],sum/2);
}
}
printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
}
return 0;
}
太丑,重写,将多重背包模板化(学背包九讲的)
//dp500-7
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1<<30;
const int SIZE=1e2+10;
int m[SIZE],v[SIZE];
int dp[130000];
void Complete_pack(int c,int w,int sum){//c为物品i的体积,w为物品i的价值
for(int i=c;i<=sum;i++)
dp[i]=max(dp[i],dp[i-c]+w);
}
void Zero_one_pack(int c,int w,int sum){
for(int i=sum;i>=c;i--){
dp[i]=max(dp[i],dp[i-c]+w);
}
}
void multiplepack(int c,int w,int num,int sum){//物品i的体积是c,价值是w,数量是num,背包的总体积是sum
if(c*num>=sum)Complete_pack(c,w,sum);
else {
int k=1;
while(k<num){
Zero_one_pack(k*c,k*w,sum);
num-=k;
k<<=1;
}
Zero_one_pack(num*c,num*w,sum);
}
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
if(n<0)break;
int sum=0;
for(int i=1;i<=n;i++){
scanf("%d%d",&v[i],&m[i]);
sum+=v[i]*m[i];
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++){
multiplepack(v[i],v[i],m[i],sum/2);
}
printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
}
return 0;
}