Longest Ordered Subsequence
Problem description |
A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). Your program, when given the numeric sequence, must find the length of its longest ordered subsequence. |
Input |
The first line of input contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000 |
Output |
Output must contain a single integer - the length of the longest ordered subsequence of the given sequence. |
Sample Input |
7 1 7 3 5 9 4 8 |
Sample Output |
4 |
Problem Source |
HNU Contest |
#include<iostream>
using namespace std;
int a[1002];
int dp[1002];
int main()
{
int n;
cin>>n;
int maxx=0;
for(int i=1;i<=n;i++){
dp[i]=1;
cin>>a[i];
for(int j=1;j<i;j++){//这里之前i与j错位了
if(a[j]<a[i]){
dp[i]=max(dp[j]+1,dp[i]);
}
}
maxx=max(maxx,dp[i]);
}
cout<<maxx<<endl;
return 0;
}