A - Ada and List SPOJ - ADALIST

Ada the Ladybug has a TODO-list (containing only numbers - for simplicity). She is still doing something, so she sometimes erases kth number, sometimes she inserts something on kth position and sometime she asks for kth number.

Sadly, she is now searching for a work at position k so she doesn't have time to do this herself. Can you help her?

Input

The first line will contain 0 < N ≤ 105,0 < Q < 5*105, the number of elements in TODO-list and number of queries.

Then a line with N numbers follows. Each number 0 ≤ Ak ≤ 109 means kth number in her TODO-list.

Afterward, Q lines follow, each beginning with number 1 ≤ a ≤ 3

k x means that you will add number x to position k

k means that you will erase number from position k

k means that you will print number from position k

For all queries, it is true that 1 ≤ k ≤ #SizeOfList0 ≤ x ≤ 109 (for query1, it can be also put to position #SizeOfList + 1)

You will never get query of type or if the list is empty

Output

For each query of type 3, print kth numbers

Example Input

6 10
1 2 4 8 16 32
3 4
1 1 7
3 2
2 2
2 2
3 2
1 6 666
3 6
2 1
3 1

Example Output

8
1
4
666
4

Queries explanations

1 2 4 8 16 32
7 1 2 4 8 16 32
7 1 2 4 8 16 32
7 2 4 8 16 32
7 4 8 16 32
7 4 8 16 32
7 4 8 16 32 666
7 4 8 16 32 666
4 8 16 32 666
4 8 16 32 666
#include <iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
vector<int > v;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int a,b,c,d;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a);
        v.push_back(a);
    }
    while(m--)
    {
        scanf("%d%d",&b,&c);
        if(b==1)
        {
            scanf("%d",&d);
            v.insert(v.begin()+c-1,d);
        }
        if(b==2)
        {
            v.erase(v.begin()+c-1);
        }
        if(b==3)
        {
            printf("%d\n",v.at(c-1));
        }
    }
    return 0;
}

#include <iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
vector<int > v;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int a,b,c,d;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a);
        v.push_back(a);
    }
    while(m--)
    {
        scanf("%d%d",&b,&c);
        if(b==1)
        {
            scanf("%d",&d);
            v.insert(v.begin()+c-1,d);
        }
        if(b==2)
        {
            v.erase(v.begin()+c-1);
        }
        if(b==3)
        {
            printf("%d\n",v[c-1]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值