自定义博客皮肤VIP专享

*博客头图:

格式为PNG、JPG,宽度*高度大于1920*100像素,不超过2MB,主视觉建议放在右侧,请参照线上博客头图

请上传大于1920*100像素的图片!

博客底图:

图片格式为PNG、JPG,不超过1MB,可上下左右平铺至整个背景

栏目图:

图片格式为PNG、JPG,图片宽度*高度为300*38像素,不超过0.5MB

主标题颜色:

RGB颜色,例如:#AFAFAF

Hover:

RGB颜色,例如:#AFAFAF

副标题颜色:

RGB颜色,例如:#AFAFAF

自定义博客皮肤

-+

原创 谷歌浏览器 喔唷 崩溃啦

周一重启了一下电脑,然后打开谷歌浏览器全报这个错误信息,即使是打开设置也一样。 卸载重装与万能的重启电脑也不行。 网上找到了些解决方案: 1.删除C:\Windows\System32\drivers下的bd0001.sys 没找到这玩意啊 2.禁用沙箱 谷歌浏览器的快捷方式属性->目标后面...

2019-12-25 09:08:55

阅读数 201

评论数 1

原创 mysql 根据条件显示特定内容

在设计数据库表中,我们喜欢用一个int值去表示多个类别,例如我们设计一张表people,type字段 0代表学生,1代表老师,2代表家长,但是在搜索展示在界面时,0,1,2不能一下子让人明了,一般的做法是搜索出来后再进行判断转化成对应的字面内容。 但是mysql其实很强大,我们可以这样来搜索: s...

2019-12-02 18:01:49

阅读数 133

评论数 0

原创 ElasticSearch按插入顺序排序

在多并发的场景下,同一秒内或是可以插入多条数据,当我们按时间进行倒序排序的时候,同一秒内的数据并不会倒着排序,那在一些业务场景内就不适用了,结果如下图: 此时我们可以增加一个条件 在每插入一条数据时,_seq_no都会自增1,所以可以使用此字段进行排序,但需要注意的是,如果对文档进行更新时,其...

2019-11-29 18:15:52

阅读数 114

评论数 0

原创 Fielddata is disabled on text fields by default

在昨天导入数据中,要一一对旧接口进行验证是否可行。 在尝试获取一个时间段的数据并排序时,发现了一个问题: “type”: “illegal_argument_exception”, “reason”: “Fielddata is disabled on text fields by default...

2019-11-20 14:08:39

阅读数 103

评论数 0

原创 ElasticSearch 6.x数据迁移ElasticSearch7.4

之前已经搭建好一个集群了。需要测试一下新版本的ES对现有的相关ES查询接口是否可重用。 那测试就需要相关数据。为了模拟一下真实的环境,那就把6.x版本的ES数据导进7.4里。 通过了解,有这个玩意可以帮助到:https://github.com/taskrabbit/elasticsearch-d...

2019-11-19 11:39:21

阅读数 178

评论数 0

原创 Centos7 添加启动脚本

因为业务的需要,在机器重启后需要执行一些脚本。 最开始,我直接在/etc/rc.d/rc.local里最下面一行添加了一句 sh /home/test.sh 需要注意的是/home/test.sh必须要有执行权限 自测之后,很OK啊,但是放上生产后,有客户反应,脚本没有被执行。 我再细看这个文件 ...

2019-10-28 09:51:08

阅读数 112

评论数 0

原创 ElasticSearch7.4 elasticsearch-head插件安装

上一篇已经部署好集群了,现在安装elasticsearch-head 插件 1.node.js 安装 curl --silent --location https://rpm.nodesource.com/setup_10.x | bash - yum install -y nodejs 2.安装...

2019-10-17 14:11:39

阅读数 137

评论数 0

原创 ElasticSearch 7.4集群部署

2台机器,系统均为Centos 7.2,主节点IP为10.45.154.236,第二节点的IP为10.45.154.70,均为内网IP。 1.下载相关软件包 到官网上下载最新版本ElasticSearch 7.4,https://www.elastic.co/cn/downloads/elast...

2019-10-16 19:00:33

阅读数 1261

评论数 0

原创 zend_class_entry’ has no member named ‘iterator_funcs’

在centos上编译php 7.3 的rar拓展的时候会出现这个错误。 error: ‘zend_class_entry’ has no member named ‘iterator_funcs’ 这是由于新的Zend代码由之前的: zend_class_iterator_funcs iterat...

2019-09-05 16:43:38

阅读数 133

评论数 1

原创 not enough arguments in call to oprot.Flush

最近打算把之前C++相关的thrift项目,改成go项目。把协议重新生成后,就开始撸一发看看。 结果第一个错误就来了:not enough arguments in call to oprot.Flush,这是因为本地生成协议的版本是0.9.3与 go get git.apache.org/th...

2019-06-25 16:33:03

阅读数 376

评论数 0

原创 Centos7升级Python3.7

背景:centos7下的python版本为2.7,而目前的项目需要使用Python 3.6或以上的版本。 wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz tar zxvf Python-3.7.0.tgz yum ...

2019-05-31 13:53:17

阅读数 1513

评论数 0

原创 centos5.8上编译libhttpserver

背景:由于项目需要支持低版本的系统,所以编译的动态库以最低支持的服务器系统为准。 libhttpserver 依赖libmicrohttpd,所以我们要先编译这个 https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-0.9.59.tar.gz 下...

2019-05-21 17:18:51

阅读数 114

评论数 0

原创 如何在低版本的libc.so的系统上安装高版本编译的rpm包

正常安装的话会出现这样的错误提示. 那第一个想法是在低版本上编译新包并可安装成功,这涉及到程序依赖的第三方库也要重新编译,繁琐,无法快速地解决问题。 于是我尝试把编译环境依赖的系统库也打包进去,一安装也是报错,链接的还是系统的libc.so库。 这就涉及到dynamic linker的事情了,需要...

2019-05-20 13:51:04

阅读数 170

评论数 0

原创 Mosaic Models:用于Porngraphic检测的深度学习模型

开源项目: https://github.com/boozyguo/mosaic 马赛克是一种高层次的神经网络模型,用Python编写的,并能够在上面运行的keras与Tensorflow后端。 现在,它的开发重点是porngraphic检测。 如果您需要深度学习模型,请使用镶嵌模型: •允许轻松...

2019-04-16 16:53:49

阅读数 375

评论数 0

原创 open_nsfw接口封装成python脚本直接调用

import os import sys import commands def index(filepath): #command = “python /home/open_nsfw/classify_nsfw.py --model_def /home/open_nsfw/nsfw_mo...

2019-04-15 15:24:52

阅读数 166

评论数 0

原创 centos下搭建open_nsfw

服务器yum源为阿里源 open nsfw是雅虎开源的一款开源的黄图识别的模型。 nsfw翻译为不可在工作中看的图片。主要是针对黄图的,恐怖,血腥图片不能识别。 在centos7.2搭建open nsfw的环境 1.安装依赖 sudo yum -y install protobuf-de...

2019-04-12 17:54:34

阅读数 243

评论数 0

原创 ubuntu下搭建open_nsfw

open_nsfw初体检 open nsfw是雅虎开源的一款开源的黄图识别的模型。 nsfw翻译为不可在工作中看的图片。主要是针对黄图的,恐怖,血腥图片不能识别。 在ubuntu 14.04搭建open nsfw的环境 执行以下命令: apt-get update sudo apt-g...

2019-04-12 14:53:16

阅读数 211

评论数 0

提示
确定要删除当前文章?
取消 删除