configure cisco EtherChannel

Catalyst 2950 Switch
Cat2950#
Cat2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.

!-- The VLAN Trunk Protocol (VTP) mode is set to server,
!-- and the VTP domain name to is set to cisco.
Cat2950(config)#vtp mode server
Setting device to VTP SERVER mode
Cat2950(config)#vtp domain cisco
Changing VTP domain name from VitalCom to cisco

!-- Created two VLANs: VLAN10 and VLAN20.
Cat2950(config)#vlan 10
Cat2950(config-vlan)#exit
Cat2950(config)#vlan 20
Cat2950(config-vlan)#exit

!-- Configured ports Fa0/5 through Fa0/14 in VLAN10,
!-- and ports fa0/15 through Fa0/26 in VLAN20.
Cat2950(config)#int range fa0/5 - 14
Cat2950(config-if-range)#switchport access vlan 10
Cat2950(config-if-range)#exit
Cat2950(config)#int range fa0/15 - 26
Cat2950(config-if-range)#switchport access vlan 20
Cat2950(config-if-range)#^Z
Cat2950#
00:32:39: %SYS-5-CONFIG_I: Configured from console by console

!-- Configured the management interface so that the switch
!-- can be accessed remotely by using Telnet.
Cat2950#conf t
Cat2950(config)#int vlan 10
Cat2950(config-if)#ip address 10.10.10.10 255.255.255.0
Cat2950(config-if)#no shutdown
00:24:07: %LINK-3-UPDOWN: Interface Vlan10, changed state to up
Cat2950(config-if)#^Z
00:24:12: %SYS-5-CONFIG_I: Configured from console by console
Cat2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.

!-- Configured the default-gateway, which is the IP address of the sub-interface
!-- on the router for VLAN 10, so that the switch can be accessed from any VLAN.
Cat2950(config)#ip default-gateway 10.10.10.1

!-- Configured a logical channel interface.
Cat2950(config)#int port-channel 1
Cat2950(config-if)#exit

!-- Ports are assigned to the logical channel interface to form an EtherChannel.
!-- Note: The channel mode on the switch is set to on because the Cisco 7200
!-- router on the other end does not support Port Aggregation Protocol(PAgP).
Cat2950(config)#int fa0/2
Cat2950(config-if)#channel-group 1 mode on
Cat2950(config-if)#exit
Cat2950(config)#
00:25:38: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:25:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up
Cat2950(config)#int fa0/3
Cat2950(config-if)#channel-group 1 mode on
Cat2950(config-if)#exit

!-- To configure trunking over EtherChannel, trunking
!-- is enabled over the logical channel interface.
Cat2950(config)#int port-channel 1
Cat2950(config-if)#switchport mode trunk
Cat2950(config-if)#
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, chang
ed state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, chang
Ed state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to down
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, chang
Ed state to up
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, chang
Ed state to up
00:27:18: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:27:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up

!-- Configured VLAN10 as the Native VLAN for untagged traffic.
Cat2950(config-if)#switchport trunk native vlan 10
Cat2950(config-if)#^Z
00:24:12: %SYS-5-CONFIG_I: Configured from console by console
Cat2950#

 

Cisco 7200 Router
Cisco7200#
Cisco7200#conf t
Enter configuration commands, one per line. End with CNTL/Z.

!-- Created a logical channel interface to form an EtherChannel.
Cisco7200(config)#int port-channel 1
Cisco7200(config-if)#exit

!-- The ports fa3/0 and fa4/0 are configured as members of the
!-- logical channel to form an EtherChannel group.
Cisco7200(config)#int fa3/0
Cisco7200(config-if)#channel-group 1

FastEthernet3/0 added as member-1 to port-channel1
Cisco7200(config-if)#exit
Cisco7200(config)#
00:25:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up
Cisco7200(config)#int fa4/0
Cisco7200(config-if)#channel-group 1

FastEthernet4/0 added as member-2 to port-channel1
Cisco7200(config-if)#exit

!-- Configured sub-interfaces over port-channel for VLAN10 and VLAN20 to configure
!-- trunking over EtherChannel. The IP address is assigned to InterVLAN routing.
!-- Configured VLAN10 as the Native VLAN for untagged traffic.
Cisco7200(config)#int port-channel 1.10
Cisco7200(config-subif)#encapsulation dot1Q 10 native
Cisco7200(config-subif)#ip address 10.10.10.1 255.255.255.0
Cisco7200(config-subif)#exit
Cisco7200(config)#int port-channel 1.20
Cisco7200(config-subif)#encapsulation dot1Q 20
Cisco7200(config-subif)#ip address 10.10.11.1 255.255.255.0
Cisco7200(config-subif)#exit
Cisco7200(config)#exit
Cisco7200#

 

 另:
 EtherChannl要求必须用支持的interface才能组成,不是你随便选interface的。变成黄色你应该用show interface看一下是不是成了error-disabled状态,如果是则需要用(config)#errdisable recovery恢复,光用shutdown是不行的。


L2 EtherChannel只用配physical interface就行了,可以是static access,也可以使trunk,但是必须一样。不需要create port-channel。

L3 EtherChannel要首先create port-channel,然后no sw把port-channel变成L3 interface,加上IP地址。再进入physical interface,必须no ip add去掉physical interface的IP信息,然后直接channel-group加入EtherChannel就行了。

给你例子:

For L2 static access EtherChannel:

Switch# configure terminal
Switch(config)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end


For L2 trunk EtherChannel:

Switch# configure terminal
Switch(config)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# switchport trunk encapsulation isl
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end


For L3 EtherChannel:

Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# no ip address
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值