PAT A1006

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

在每一天的开始,第一个进入机房的人将 把门打开,最后一个离开的人 把门 锁住。给出 进入和退出机房的人的记录,你将在那天找到谁 开门和关门

输入格式

每个文件包含一个测试用例,每个用例包含 一天的记录。 用例 从 M 开始,M——总共M条记录,然后下面 接着 M 行,每行的格式是这样的:每个时间的格式 都是  HH:MM:SS,每个 id number 都是一个不多于15个字符的字符串

输出格式:

对于每一个测试用例,在一行输出 那天 谁 开门 锁门,两个 idnumber 必须以空格分隔开

注意:记录都是保证一致的,意味着,登录的时间必须比退出机房时间早 对于每个人来说,然后没有两个人在同一时间登录和退出

思路:

把每个人的登录时间和退出时间都和00:00:00相减,最后的差值(以秒为单位),比较看谁的差值最小,谁就是第一个机房的人,谁的差值最大就是最后一个离开机房的人。

#include <cstdio>
struct{
	char name[20];
	int etime;
	int ltime;
}per[10010];
int main(){
	int m;
	scanf("%d", &m);
	int h1, h2, m1, m2, s1, s2, temp1, temp2;
	int k = 0;
	for(int i = 0; i < m; i++){
		scanf("%s %d:%d:%d %d:%d:%d", per[i].name, &h1, &m1, &s1, &h2, &m2, &s2);
		temp1 = h1 * 3600 + m1 * 60 + s1;
		temp2 = h2 * 3600 + m2 * 60 + s2;
		per[i].etime = temp1;
		per[i].ltime = temp2;
		k++;
	}
	int max = -1;
	int min = 86401;
	int kmax = 0;
	int kmin = 0;
	for(int i = 0; i < k; i++){
		if(per[i].etime < min){
			min = per[i].etime;
			kmin = i;
		}			
		if(per[i].ltime > max){
			max = per[i].ltime;
			kmax = i;
		}
	}
	printf("%s %s", per[kmin].name, per[kmax].name);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值