P - Answering Queries LightOJ - 1369

                                                                                   

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers andn is the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int i = 0; i < n; i++ )

        for( int j = i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4

Hint

Dataset is huge, use faster I/O methods.


题意:给你一个序列,按照提上给出的程序算出和,然后q次操作,当q为1,输出结果,否则为0,然后将其第几个数变为另一个数,然后在算出和输出;

思路:一开始我连输出都没搞懂,真菜QAQ...,其实递推一下规律就可以知道,第n项的系数为n-2*j-1,这里的指的是第几项。。。。然后在下面的操作中我们只要将改变的数减去其乘积在加上新的数的乘积即可,注意,换数的时候要把换的结果保留下来。。(菜鸡因为这错了好几遍QAQ)

下面附上我的代码:


#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=100010;
ll p[N],m[N];
int main()
{
	int t,n,q,a,h=0;
	ll b,c;
	cin>>t;
	while(t--)
	{
		cin>>n>>q;
		for(ll i=0;i<n;i++)
			cin>>p[i];
		ll sum=0;
		for(ll j=0;j<n;j++)
				sum+=((n-1)-j*2)*p[j];
		printf("Case %d:\n",++h);
		for(ll i=0;i<q;i++)
		{
			scanf("%d",&a);
			if(a==1) 
			{
				printf("%lld\n",sum);
			}
			else
			{
				scanf("%lld %lld",&b,&c);
				sum=sum+((n-1)-2*b)*(c-p[b]);
				p[b]=c;//一定记者要替换,否则当他在同一个位置改数的时候结果就错了 
			}
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值