Machine(模拟)

There is a machine with m(2≤m≤30)m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 
For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed n(1≤n<263)n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15)T(1≤T≤15) indicating the number of test cases. For each test case: 

The only line contains two integers m(2≤m≤30)m(2≤m≤30) and n(1≤n<263)n(1≤n<263).

Output

For each test case, output the colour of m bulbs from left to right. 
R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

分析:由题意知道,按一次变成G,按两次变成B,按三次变成R,相当于取模运算,从最后一位开始存储n%3的值,每向前移动一位就给n/3。不过刚开始数组要初始化为0;刚开始我给数组存的是字符,但是数字大了以后打印的时候会出现乱码,所以最后就考虑存储数字了。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int  color[32];
int main()
{
    long long n;
    int m;
    int T;

    scanf("%d",&T);
    while(T--)
    {
        memset(color,0,sizeof(color));
        int i=1;
        scanf("%d%lld",&m,&n);
        while(n)
        {
           color[m-i]=n%3;
            n=n/3;
            i++;
        }
        //cout<<endl;/*
        for(int i=0;i<m;i++)
           {
               if(color[i]==0)printf("R");
               else if(color[i]==1)printf("G");
               else if(color[i]==2)printf("B");
           }
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值