HDU-3974(dfs序获得时间戳建立线段树)

题目:

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree. 

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one. 

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases. 

For each test case: 

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees. 

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N). 

The next line contains an integer M (M ≤ 50,000). 

The following M lines each contain a message which is either 

"C x" which means an inquiry for the current task of employee x 

or 

"T x y"which means the company assign task y to employee x. 

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2

通过dfs序将每个节点出现的次序找到,就会是一个连续的序列,这样每个节点的子树就相当于一个区间,c操作和T操作就相当于区间询问和区间更新,就转化成线段树的操作。前边都是线段树的模板。l[]和r[],分别代表子树根节点的位置和子树最后一个节点的位置,这样即相当于一个区间。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;

const int maxn = 50005;
int l[maxn],r[maxn];
int st[maxn << 3];
bool vis[maxn];
vector<int>E[maxn];
void pushdown(int  p)
{
    if(st[p] != -1)
    {
        st[p << 1] = st[p];
        st[p << 1|1] = st[p];
        st[p] = -1;
    }
}
void build(int p,int l,int r)
{
    st[p] = -1;
//设置初始值放在if外边。
    if(l == r){
    return ;
    }
    int m = (l + r) >> 1;
    build(p << 1,l,m);
    build(p << 1|1,m + 1,r);
}

void update(int p,int l,int r,int x,int y,int k)
{
    if(x <=l && r <= y)
    {
        st[p] = k;
        return ;
    }
    pushdown(p);
    int m = (l + r) >> 1;
    if(x <= m) update(p << 1,l,m,x,y,k);
    if( y > m) update(p << 1|1,m + 1,r,x,y,k);
}

int query(int p,int l,int r,int x)
{
    if(l == r)
    return st[p];
    pushdown(p);
    int m = (l + r) >> 1;
    if(x <= m)query(p << 1,l,m,x);
    else query(p << 1|1,m + 1,r,x);
}
//dfs序
void dfs(int u,int &cnt)//加上&,不然会wa
{
    l[u] = cnt ++;//节点开始的次序。
    for(int i = 0;i < (int)E[u].size();i ++)
    {
        int tmp = E[u][i];
        dfs(tmp,cnt);
    }
    r[u] = cnt ++;//节点叶子节点最后次序。
}
int main()
{
    int t;
    scanf("%d",&t);
    int Case = 0;
    while(t --)
    {
        int n,m;
        scanf("%d",&n);
        build(1,1,2 * n);//其实只需要建 cnt 那么大的树就可以了。
        memset(l,-1,sizeof l);
        memset(r,-1,sizeof r);
        for(int i = 1;i <= n;i ++)
            {
                vis[i] = 0;E[i].clear();
            }
        for(int i = 0,u,v;i < n - 1;i ++)
        {
            scanf("%d%d",&u,&v);
            E[v].push_back(u);
            vis[u] = 1;             //找根节点,有向树。
        }
        int cnt = 1;
        for(int i = 1;i <= n;i ++)
        {
            if(vis[i] == 0)
                dfs(i,cnt);
        }
        printf("Case #%d:\n",++Case);
        scanf("%d",&m);
        char ch[2];
        while(m --)
        {
            scanf("%s",ch);
            int x,y;
            if(ch[0] == 'T')
            {
                scanf("%d%d",&x,&y);
                update(1,1,2*n,l[x],r[x],y);//l[]-r[],存的是该节点的相当于x所代表的区间的长度。
            }
            else if(ch[0] == 'C')
            {
                scanf("%d",&x);
                printf("%d\n",query(1,1,2*n,l[x]));//l[x]是x的位置,序号。
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值