lightOJ - 1030(概率dp)

题目:LightOJ - 1030 

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题意:一个山洞由n个格子组成 ,每个格子都有不同数量的金子,初始位置在第一个格子,每次扔骰子来决定向前的步数,但是如果超过了n就要重新扔,直到走到最后一个格子才算结束。让你求获得金子的期望值。

分析:类似于爬楼梯问题,每个格子可由其前边的6个格子转移过来,可以计算出走到每个格子的概率,乘每个格子的金子数,最后相加就是答案。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std;

const int maxn = 105;
double dp[maxn];
int grid[maxn];
int n;

int main()
{
    int T,Case = 0;
    cin >> T;
    while(T --)
    {
        cin >> n;
        for(int i = 1;i <= n;i ++)
        {
            cin >> grid[i];
        }
        memset(dp,0,sizeof(dp));
        dp[1] = 1;
        for(int i = 1;i <= n;i ++)
        {
            int k = min(6,n - i);
            for(int j = 1;j <= k;j ++)
            {
                dp[i + j] += dp[i] * (1.0 / k);
            }
        }
        double ans = 0;
        for(int i = 1;i <= n;i ++)
        {
            ans += dp[i] * grid[i];
        }
        printf("Case %d: %.10lf\n",++ Case,ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值