lightOJ - 1104(概率与期望)

题目:LightOJ - 1104 

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

题意:在一个房间中,至少有23个人就可以使两个人生日相同的概率大于0.5,现在给出你一年的天数,求出至少需要多少人可以使两个人生日相同的概率至少为0.5;

分析:至少两个人生日相同的概率 = 1 - 所有人生日都不同的概率 

所有人生日都不同的概率 P = 1*(n - 1)/n * (n -2)/n * (n - 3)/ n*······*(n - m) / n;

#include <iostream>
#include <stdio.h>

using namespace std;

const int maxn = 100005;


int main()
{
    int T,Case = 0;
    int n;
    cin >> T;
    while(T --)
    {
        cin >> n;
        int cnt = n;
        int ans = 0;
        double p = 1;
        while(p > 0.5)
        {
            cnt --;
            p = p * cnt / n;
            ans ++;
        }
        printf("Case %d: %d\n",++ Case,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值