杭电acm1093
A+B for Input-Output Practice (V)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27457 Accepted Submission(s): 18634
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
24 1 2 3 45 1 2 3 4 5
Sample Output
1015
Author
lcy
代码:
#include <iostream>
using namespace std;
int main()
{
int N,a,b,sum;
int *p;
int Num;
cin>>Num;
while(Num--)
{
cin>>N;
sum = 0;
p = new int[N];
for(int i=0;i<N;i++)
{
cin>>p[i];
sum += p[i];
}
cout<<sum<<endl;
delete p;
p = NULL;
}
return 0;
}