1054 求平均值(PAT 乙级 C++实现)

1054 求平均值 (20)(20 point(s)) 

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析:

 

详细代码:

#include <iostream>     
#include <string>
#include <iomanip>
using namespace std;

// 1054 求平均值 (20)(20 point(s))
int main(void){   
	int n; cin>>n;

	int total=n;
	double sum = 0.0;
	for(int i=0;i<n;++i){
		string t; cin>>t;
		int dotx = 0,dotlocal=0;
		int flag=0;
		for(int j=0;j<t.length();++j){
			if(t[j]>='0'&&t[j]<='9'){
				if(dotlocal != 0){
					++dotlocal;
					if(dotlocal>3){
						flag = 1;
						break;
					}
				}
			}else if(t[j]=='.'){
				dotx += 1;
				if(dotx==1){
					dotlocal += 1;
				}else if(dotx>=2){ 
					flag = 1;
					break;
				}
			}else if(t[j]=='-'){
				if(j==0){
					continue;
				}else{
					flag = 1;
					break;
				}
			}else{
				flag = 1;
				break;
			} 
		}

		if(flag == 0){
			double x = stof(t);
			if(x<(-1000) || x>1000){
				flag = 1;
			}else{
				sum += x;
			}
		} 
		if(flag != 0){
			--total;
			cout<<"ERROR: "<<t<<" is not a legal number"<<endl; 
		}
	}

	if(total==0){
		cout<<"The average of 0 numbers is Undefined"<<endl;
	}else if(total==1){ // 注意为 1 是要分开输出 不然有一个 case 过不了
		cout<<"The average of 1 number is "<<fixed<<setprecision(2)<<sum<<endl; 
	}else{
		cout<<"The average of "<<total<<" numbers is "<<fixed<<setprecision(2)<<(1.0*sum/total)<<endl;
	}

	return 0;
}// jinzheng 2018.7.28 17:50
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值