AcWing852- spfa判断负环(java实现)

AcWing852- spfa判断负环

题目描述

给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环, 边权可能为负数

请你判断图中是否存在负权回路。

输入格式

第一行包含整数 n 和 m。

接下来 m 行每行包含三个整数 x,y,z,表示存在一条从点 x到点 y 的有向边,边长为 z。

输出格式

如果图中存在负权回路,则输出 Yes,否则输出 No

数据范围

1≤n≤2000,
1≤m≤10000,
图中涉及边长绝对值均不超过 10000。

输入样例:

3 3
1 2 -1
2 3 4
3 1 -4

输出样例:

Yes

题解

package acWing852;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.LinkedList;
import java.util.Queue;
public class Main {
	static int max = 0x3f3f3f3f;
	static int N = 2010, M = 10010;
	static int n,m;
	static int h[] = new int[N],e[] = new int[M],ne[] = new int[M],w[] = new int[M],idx;
	static int dist[] = new int[N],cnt[] = new int[N];
	static Boolean[] st = new Boolean[N];
	static void add(int a, int b,int c) {
		e[idx] = b;w[idx] = c;ne[idx] = h[a];h[a] = idx++;
	}
    
	static String spfa() {
		Queue<Integer> q = new LinkedList<>();
		for(int i=1;i<=n;i++) {
			st[i] = true;
			q.add(i);
		}
		while(!q.isEmpty()) {
			int t = q.poll();
			st[t] = false;
			for(int i=h[t];i!=-1;i=ne[i]) {
				int j = e[i];
				if(dist[j]>dist[t]+w[i] ){
					dist[j] = dist[t] +w[i];
					cnt[j] = cnt[t] +1;
					if(cnt[j]>=n) {
						return "Yes";
					}
					if(!st[j]) {
						q.add(j);
						st[j] = true;
					}
				}
			}
		}
		return "No";
	}
    
	public static void main(String[] args) throws IOException {
		BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
		String str[] = bf.readLine().split(" ");
		n = Integer.parseInt(str[0]);m = Integer.parseInt(str[1]);
		Arrays.fill(h, -1);
		Arrays.fill(dist, max);
		Arrays.fill(st, false);
		for(int i=0;i<m;i++) {
			str = bf.readLine().split(" ");
			int a = Integer.parseInt(str[0]),b = Integer.parseInt(str[1]),c = Integer.parseInt(str[2]);
			add(a,b,c);
		}
		System.out.println(spfa());
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

杜柠函

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值