AcWing860-染色法判定二分图(java实现)

AcWing860-染色法判定二分图

题目描述

给定一个 n 个点 m 条边的无向图,图中可能存在重边和自环。

请你判断这个图是否是二分图。

输入格式

第一行包含两个整数 n 和 m。

接下来 m 行,每行包含两个整数 u 和 v,表示点 u 和点 v 之间存在一条边。

输出格式

如果给定图是二分图,则输出 Yes,否则输出 No

数据范围

1≤n,m≤10^5

输入样例:

4 4
1 3
1 4
2 3
2 4

输出样例:

Yes

题解

package acWing860;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;

public class Main {
    static int n,m;
    static int N = 100010, M = 200010;
    static int h[] = new int[N],e[] = new int[M],ne[] = new int[M],idx = 0;
    static int[] color = new int[N];	//	共1和2两种不同的颜色
    static boolean[] st = new boolean[N];
    public static void add(int a,int b){
        e[idx] = b;ne[idx] = h[a];h[a] = idx ++;
    }
    //	dfs(u,c)表示把u号点染色成c颜色,并且判断从u号点开始染其他相连的点是否成功
    public static boolean dfs(int u,int c){
        color[u] = c;
        for(int i = h[u];i != -1;i = ne[i]){
            int j = e[i];
            if(color[j] == 0){
                if(!dfs(j,3 - c)) return false;
            }else if(color[j] == c) return false;//颜色重复
        }
        return true;
    }
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        String[] str = reader.readLine().split(" ");
        n = Integer.parseInt(str[0]);m = Integer.parseInt(str[1]);
        Arrays.fill(h, -1);
        while(m-->0){
            str = reader.readLine().split(" ");
            int a = Integer.parseInt(str[0]);
            int b = Integer.parseInt(str[1]);
            add(a,b);add(b,a);
        }
        boolean flag = true;	//	标记是否染色成功
        for(int i = 1;i <= n;i++){
            //	若未染色
            if(color[i] == 0){
                if(!dfs(i,1)){
                    flag = false;
                    break;
                }
            }
        }
        System.out.println(flag ? "Yes" : "No");
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

杜柠函

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值