A Simple Game

HDOJ1851:

    

Problem Description
Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M 1 stones, the 2nd pile has M 2 stones, ... and the n-th pile contain M n stones. Agrael and Animal take turns to move and in each move each of the players can take at most L 1stones from the 1st pile or take at most L 2 stones from the 2nd pile or ... or take L n stones from the n-th pile. The player who takes the last stone wins.

After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
 

Input
The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers M i and L i (20 ≥ M i > 0, 20 ≥ L i > 0). 
 

Output
Your program output one line per case, if Agrael can win the game print "Yes", else print "No". 
 

Sample Input
  
  
2 1 5 4 2 1 1 2 2
 

Sample Output
  
  
Yes No
 

Author
Agreal@TJU
 

Source
 

Recommend
lcy


#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int T,n,m,l,sum;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&m,&l);
            sum^=m%(l+1);
        }
        if(!sum)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure, I can help you with that. Here's an implementation of the Dice class: ```python import random class Dice: def __init__(self, num_sides): self.num_sides = num_sides def roll(self): return random.randint(1, self.num_sides) ``` This class has a constructor that takes in the number of sides of the dice and a roll method that returns a random number between 1 and the number of sides. To create a simple game using this class, we can do the following: ```python num_players = int(input("Enter the number of players: ")) num_sides = int(input("Enter the number of sides on the dice: ")) winning_score = int(input("Enter the winning score: ")) players = [] for i in range(num_players): players.append({'id': i+1, 'score': 0, 'rolls': 0, 'dice': Dice(num_sides)}) winner = None while not winner: for player in players: roll = player['dice'].roll() player['score'] += roll player['rolls'] += 1 print(f"Player {player['id']} rolled a {roll}. Current score: {player['score']}") if player['score'] >= winning_score: winner = player break print(f"\nPlayer {winner['id']} won with a score of {winner['score']} after {winner['rolls']} rolls.") ``` This code prompts the user for the number of players, the number of sides on the dice, and the winning score. It then creates a list of player dictionaries, each containing an ID, score, number of rolls, and a Dice object. The game loop iterates through each player, rolls their dice, updates their score and number of rolls, and checks if they have reached the winning score. If a player has reached the winning score, the game loop ends and the winner is announced.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值