113 - Power of Cryptography

Uva

113 - Power of Cryptography


 Power of Cryptography 

Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

The Problem

Given an integer tex2html_wrap_inline32 and an integer tex2html_wrap_inline34 you are to write a program that determines tex2html_wrap_inline36 , the positive tex2html_wrap_inline38 root of p. In this problem, given such integers n and pp will always be of the form tex2html_wrap_inline48 for an integer k (this integer is what your program must find).

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs tex2html_wrap_inline56 ,tex2html_wrap_inline58 and there exists an integer ktex2html_wrap_inline62 such that tex2html_wrap_inline64 .

The Output

For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the number k such that tex2html_wrap_inline64 .

Sample Input

2
16
3
27
7
4357186184021382204544

Sample Output

4
3
1234

p不是很大,可以用double(最大1.8*10^308)存储。

k^n=p,经变换有k=p^(1/n),可用math.h中的pow()函数,或

对两边取对数,有n*ln(k)=ln(p)  => ln(k)=ln(p)/n =>k=e^(ln(p)/n),求ln(p),可以math.h中的log()函数

或者复杂一点用 二分+高精度

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    double n,p;
    while(cin>>n>>p)
        cout<<(int)(pow(p,1.0/n)+0.5)<<endl;//在貌似poj的数据数据较水,注意精度;
    return 0;
}


#include <iostream>
#include <cmath>
using namespace std;
int main(int argc, char **argv)
{
	double n,p;
    while(cin>>n>>p)
        cout<<(int)(exp(log(p)/n)+0.5)<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值