HDOJ--1171--Big Event in HDU

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30206    Accepted Submission(s): 10606


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 
思路:与01背包有些不同的就是,给出的物品中,有一部分物品的件数并非是一件。所以需要我们去想办法让他们尽可能的接近01背包的状态。
ac代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1010*1010];
int main(){
	int N;
	int weight[1010*1010],num,V,sum,i;
	while(scanf("%d",&N)!=EOF){
		if(N<0)//注意题目中的要求,对于负整数的话结束运行。 
			break;
		sum=0;
		int cnt=0,v;
		for(i=0;i<N;i++){
			scanf("%d%d",&v,&num);//与01背包不同的是有的东西有多件,需考虑这个问题。 
			sum+=v*num;
			while(num--){
				weight[cnt++]=v;
			}
		}
		V=sum/2;
		memset(dp,0,sizeof(dp));
		for(i=0;i<cnt;i++){
			for(int j=V;j>=weight[i];j--)
			dp[j]=max(dp[j],dp[j-weight[i]]+weight[i]);
		}
		printf("%d %d\n",sum-dp[V],dp[V]);	 
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值