顺序表应用2:多余元素删除之建表算法

顺序表应用2:多余元素删除之建表算法

Time Limit: 3ms   Memory limit: 600K  有疑问?点这里^_^

题目描述

一个长度不超过10000数据的顺序表, 可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
       1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
       2、本题的目标是熟悉在顺序表原表空间基础上建新表的算法,要在原顺序表空间的基础上完成完成删除,建表过程不得开辟新的表空间;
       3、不得采用原表元素移位删除的方式。

输入

  第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。

输出

   输出有n行,为每个顺序表删除多余元素后的结果

示例输入

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

示例输出

6 9 8
5
9 8 7 6 5
1 2 3 4 5

提示

 

来源

 

示例程序

 
#include<stdio.h>  
#include<stdlib.h>  
struct node  
{  
    int data;  
    struct node *next;  
};  
struct node *creat(struct node *head,int n)  
{  
    int i,m;  
    struct node *p,*q,*tail;  
    q=head;  
    for(i=0;i<n;i++)  
    {  
        scanf("%d",&m);  
        if(i==0)  
        {  
            p=(struct node *)malloc(sizeof(struct node));  
            p->data=m;  
            p->next=q->next;  
            q->next=p;  
            q=p;  
        }  
        else  
        {  
           tail=head;  
           tail=tail->next;  
           while(tail!=NULL)  
           {  
               if(tail->data==m)  
                break;  
               tail=tail->next;  
           }  
           if(tail==NULL)  
           {  
            p=(struct node *)malloc(sizeof(struct node));  
            p->data=m;  
            p->next=q->next;  
            q->next=p;  
            q=p;  
           }  
        }  
    }  
    return head;  
}  
int main()  
{  
    struct node *head,*p,*q;  
    int i,j,m,n,k,t;  
    scanf("%d",&n);  
    while(n--)  
    {  
        head=(struct node *)malloc(sizeof(struct node));  
        head->next=NULL;  
        scanf("%d",&m);  
        head=creat(head,m);  
        p=head;  
        p=p->next;  
        i=0;  
        while(p!=NULL)  
        {  
            if(i==0)  
            printf("%d",p->data);  
            else  
                printf(" %d",p->data);  
            i++;  
            p=p->next;  
        }  
        printf("\n");  
    }  
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值