Doubles
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22
your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
1 4 3 2 9 7 18 22
your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
输入
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
输出
The output will consist of one line per input list, containing a count of the items that are double some other item.
示例输入
1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
示例输出
3 2 0
提示
来源
面向对数据结构和算法不太了解的同学
示例程序
#include<stdio.h>
double a[10000];
int set ()
{
int i=0,j,k=0,l;
scanf("%lf",&a[i]);
if(a[i]==-1)
return -1;
while(a[i]!=0)
{
i++;
scanf("%lf",&a[i]);
}
for(j=0;j<i;j++)
for(l=0;l<i;l++)
if(a[j]*2==a[l])
k++;
return k;
}
int main()
{
int i,j,k,t;
double n,m;
while((t=set())!=-1)
{
printf("%d\n",t);
}
}