Lowest Bit

Lowest Bit

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.  

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
 
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

输入

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

输出

For each A in the input, output a line containing only its lowest bit.

示例输入

26
88
0

示例输出

2
8

提示


来源

面向对数据结构和算法不太了解的同学

示例程序

 
#include<stdio.h>  
int main()  
{  
    int i,j,n,m;  
    while(scanf("%d",&n)&&n)  
    {  
        m=1;  
        for(i=0;n%2==0;i++)  
        {  
            n=n/2;  
        }  
        for(j=1;j<=i;j++)  
        {  
            m*=2;  
        }  
        printf("%d\n",m);  
    }  
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值