acm--Lowest Bit

文章目录

题目

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26
88
0

Sample Output
2
8

分析

因为输入A的范围小于100,所以定义一个有效长度为8的整型数字存放二进制数据,遍历数组,遇到第一个1后跳出循环,用pow()函数即可得到正确结果

代码
#include<stdio.h>
#include<math.h>
int main(){
	int a,j,k,i,result;
	int s[8];
	while(scanf("%d",&a)!=EOF&&a){
		i=0;
		while(a){
			s[i] = a % 2;
			a = a / 2;
			i++;
		}
		for(j=0;j<i;j++)
			if(s[j]==1)  break;
		result =  pow(2,j);
		printf("%d\n",result);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值