IP Address

IP Address

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:

输入

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

输出

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

示例输入

4
00000000000000000000000000000000 
00000011100000001111111111111111 
11001011100001001110010110000000 
01010000000100000000000000000001

示例输出

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

提示

 

来源

 

示例程序

 
#include<stdio.h>  
#include<math.h>  
int main()  
{  
    int i,j,n,m,k,t,x1,x2,x3,x4;  
    char a[50];  
    scanf("%d",&n);  
    while(n--)  
    {  
        x1=0;  
        x2=0;  
        x3=0;  
        x4=0;  
        scanf("%s",a);  
        for(i=0,j=7;i<8;i++,j--)  
            if(a[i]=='1')  
            x1+=pow(2,j);  
        for(i=8,j=7;i<16;i++,j--)  
            if(a[i]=='1')  
            x2+=pow(2,j);  
        for(i=16,j=7;i<24;i++,j--)  
            if(a[i]=='1')  
            x3+=pow(2,j);  
        for(i=24,j=7;i<32;i++,j--)  
            if(a[i]=='1')  
            x4+=pow(2,j);  
        printf("%d.%d.%d.%d\n",x1,x2,x3,x4);  
    }  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值