1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1

题目大意:

如果一个数正着写和反着写是相同的话,那么这个数字为回文数。例如,1234321是一个回文数。所有的个位数都是回文数。
尽管回文数在在十进制中最常被考虑,但回文的概念应用于任何数字系统中的自然数。在b>2的基础上考虑N>0,用标准的符号表示k+1数字ai为(aibi)从0到k的求和,这里,像往常一样,0 <= ai < b,对所有i和ak都是非零的。如果只有ai = aki,则N是回文,0在任何基础上都是0,根据定义,它也是回文。给定任何非负十进制整数N和一个基底b,你应该判断出以b为基底的N是否为一个回文数。
输入规格:
每个测试文件包含一个测试用例。每个测试用例有两个非负整数N和b组成,其中0<=N<=109是十进制数2 <= b <= 109是基数。数字被一个空间隔开。
输出规范:
对于每个测试用例,如果N是基于b的回文数字,打印出“Yes”或者“No”。然后在下一行中,将N作为b中的数字,以“ak-1……”a0”。注意,在输出结束时必须没有额外的空间。

代码:

#include<stdio.h>
int a[100],i=0;
int exchange(int x,int radix)
{
    int j,n=0;
    while(x)
    {
       a[i++]=x%radix;
       x/=radix;
    }
    for(j=0;j<i;j++)
    {
        n*=radix;
        n+=a[j];
    }
    return n;
}
int main()
{
    int j,n,m,k,t;
    scanf("%d %d",&n,&m);
    if(n==0)
    {
        printf("Yes\n");
        printf("0");
        return 0;
    }
    k=exchange(n,m);
    if(n==k)
        printf("Yes\n");
    else
        printf("No\n");
    for(j=i-1;j>=0;j--)
    {
        if(j==i-1)
            printf("%d",a[j]);
        else
            printf(" %d",a[j]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值