1019 General Palindromic Number (20 分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as
Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai =a(k−i) for all i. Zero is written 0 in any base and is also palindromic by definition.Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10^9 is the decimal number and 2 ≤ b ≤ 10 ^9 is the base. The numbers are separated by a space.
Output Specification
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “ak ak−1 … a0”. Notice that there must be no extra space at the end of output.
Sample Input 1
27 2
Sample Output 1
Yes
1 1 0 1 1
Sample Input 2
121 5
Sample Output 2
No
4 4 1
题意
判断一个数在b进制下是否是回文数,并且输出该数的d进制形式。
代码
#include <iostream>
using namespace std;
int len=0;
int arr[100];
bool ispalindromic(int arr[],int len) { //判断是否是回文数
for(int i=0,j=len-1; i<len,j>=0; i++,j--) {
if(arr[i]!=arr[j]) return false;
}
return true;
}
int main() {
int n,b; //十进制数,b进制
cin >> n >> b;
do {
arr[len++] = n % b;
n = n / b;
} while(n!=0);
if(ispalindromic(arr,len))
cout << "Yes" << endl;
else
cout << "No" << endl;
for(int i=len-1; i>=0; i--) {
if(i==0) cout<< arr[i];
else cout << arr[i] << " ";
}
return 0;
}