1033. To Fill or Not to Fill (25)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

题目大意:

有了高速公路,从杭州开车到其他任何城市都很容易。但是由于汽车的油箱容量有限,我们不得不时不时的在途中找加油站。不同的加油站汽油的价格不同。你的任务是精心设计最便宜的路线。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,第一行包含4个正整数:Cmax(<=100),油箱的最大容量;D(<=30000),表示从杭州到目的城市的距离;Davg(<=20)单位汽油所能行驶的平均距离;N(<=500),加油站的数量。接下来是N行,每行包含一对非负数字:Pi汽油的单价,Di(<=D),离杭州的距离,对于数字i=1,...,N.所有的数字在一行上并用空格隔开。
输出规范:
对于每个测试用例,在一行上打印出最便宜的价格,精确到小数点后2位。假设开始油箱是空的。如果不可能到到目的地,打印“最大旅行距离=X”其中X为汽车可以到达的最远的距离,精确到小数点后两位。

代码:

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct station
{
    double price;
    double distance;
}stat[501];
bool cmp(station a,station b)
{
    if(fabs(a.distance-b.distance)>1e-6)
        return a.distance<b.distance;
    else
        return a.price<b.price;
}
int main()
{
    int i,j,t,index,minindex,flag;
    double m,n,k,minprice,sum,rest,l;
    scanf("%lf %lf %lf %d",&n,&m,&k,&t);
    for(i=0;i<t;i++)
    {
       scanf("%lf %lf",&stat[i].price,&stat[i].distance);
    }
    sort(stat,stat+t,cmp);
    if(stat[0].distance!=0)
    {
        printf("The maximum travel distance = %.2lf\n",0);
        return 0;
    }
    sum=0;
    rest=0;
    l=0;
    for(i=0;i<t-1;)
    {
        minprice=-1;
        flag=0;
        if(i+1<t)
        {
            if(stat[i+1].distance-stat[i].distance>n*k)
            {
                printf("The maximum travel distance = %.2lf\n",stat[i].distance+n*k);
                return 0;
            }
        }
        for(j=i+1;stat[i].distance+n*k>=stat[j].distance&&j<t;j++)
        {
            if(stat[i].price>=stat[j].price)
            {

                flag=1;
                sum+=((stat[j].distance-stat[i].distance)/k-rest)*stat[i].price;
                i=j;
                rest=0;
                break;
            }
            if(minprice==-1)
            {
                minprice=stat[j].price;
                index=j;
            }
            else
            {
               if(minprice>stat[j].price)
               {
                minprice=stat[j].price;
                index=j;
               }
            }
        }
        if(flag==0&&minprice!=-1)
        {
            if(stat[i].distance+n*k>=m)
            {
                sum+=(m-stat[i].distance)/k*stat[i].price;
                printf("%.2lf\n",sum);
                return 0;
            }
          sum+=(n-rest)*stat[i].price;
          rest=n-(stat[index].distance-stat[i].distance)/k;
          i=index;
        }
        if(i==t-1)
        {
            if(stat[i].distance+n*k>=m)
            {
                sum+=(m-stat[i].distance)/k*stat[i].price;
                printf("%.2lf\n",sum);

            }
            else
            {
               printf("The maximum travel distance = %.2lf\n",stat[i].distance+n*k);
            }
            return 0;
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值