1043. Is It a Binary Search Tree (25)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

题目大意:

一个二叉搜索树(BST)被递归定义为二叉树,它具有以下属性:
节点的左子树的键值小于节点的键值。
节点的右子树的键值大于等于节点的键值。
做右子树都必须是二叉搜索树。
如果我们交换每个节点的左子树和右子树,那么结果就成为BST的镜像。
现在给定一个整数序列,你的任务是判断它是BST的前序遍历还是BST的镜像。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,第一行包含一个正整数N(<=1000)。然后接下来一行给出N个整数键。直线上得所有数字用空格隔开。
输出规范:
对于每个测试用例,如果序列是BST的前序遍历序列或BST的镜像,则在第一行打印“YES”,否则打印“NO”。然后如果答案是“YES”,则在下一行打印树的后序序列。直线上得所有数字都必须有一个空格隔开,并在这一行的末端没有多余的空格。

代码:

#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *lchild,*rchild;
};
int a[1001],flag;
struct node * preordercreate(int s,int e)
{
    if(s>e)
        return NULL;
    struct node *root=(struct node *)malloc(sizeof(struct node));
    root->data=a[s];
    int i,j;
    for(i=s+1;i<=e&&a[s]>a[i];i++);
    for(j=i;j<=e;j++)
    {
        if(a[s]>a[j])
            flag=1;
    }
    root->lchild=preordercreate(s+1,i-1);
    root->rchild=preordercreate(i,e);
    return root;
}
struct node * mirrorcreate(int s,int e)
{
    if(s>e)
        return NULL;
    struct node *root=(struct node *)malloc(sizeof(struct node));
    root->data=a[s];
    int i,j;
    for(i=s+1;i<=e&&a[s]<=a[i];i++);
    for(j=i;j<=e;j++)
    {
        if(a[s]<=a[j])
            flag=1;
    }
    root->lchild=mirrorcreate(s+1,i-1);
    root->rchild=mirrorcreate(i,e);
    return root;
};
int tag=0;
void posttraverl(struct node *T)
{
    if(T)
    {

        posttraverl(T->lchild);
        posttraverl(T->rchild);
        if(tag==0)
        {
            printf("%d",T->data);
            tag=1;
        }
        else
        {
            printf(" %d",T->data);
        }
    }
}

int main()
{
    int i,j,n,m,k,t;
    struct node *root;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    flag=0;
    root=preordercreate(0,n-1);
    if(flag==0)
    {
        printf("YES\n");
        posttraverl(root);
        return 0;
    }
    flag=0;
    root=mirrorcreate(0,n-1);
    if(flag==0)
    {
       printf("YES\n");
       posttraverl(root);
       return 0;
    }
    else
    {
        printf("NO\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值