1058. A+B in Hogwarts (20)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

题目大意:

如果你是《哈利·波特》的粉丝,你就会知道魔法世界有自己的货币体系——海格向哈利解释道,“17个西克尔斯顶一个加仑,29个克努茨顶一个西克尔斯,这太简单了”。你的任务是编写一个程序来计算A+B,其中A和B以标准形式加仑.西克尔斯.克努茨给出。(加仑是一个[1,10的7次方]的整数,西克尔斯是一个[0,17)中的整数,克努茨是一个[0,29)中的整数)。
输入规范:
每个输入文件包含一个测试用例,该测试用例在以A和B标准格式中占用一行,有一个空格隔开。
输出规范:
对于每个测试用例,您应该在一行中输出A和B的和,于输入的格式相同。

代码:

#include<stdio.h>
int main()
{
    int i,j,n,x1,x2,x3,y1,y2,y3,z1,z2,z3;
    scanf("%d.%d.%d %d.%d.%d",&x1,&x2,&x3,&y1,&y2,&y3);
    z1=0;
    z2=0;
    z3=0;
    z1=x3+y3;
    if(z1>=29)
    {
        z1=z1%29;
        z2+=1;
    }
    z2+=(x2+y2);
    if(z2>=17)
    {
        z2=z2%17;
        z3+=1;
    }
    z3+=(x1+y1);
    printf("%d.%d.%d\n",z3,z2,z1);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值