1108. Finding Average (20)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:


代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
    int i,j,n,m,k,t,l,p,x,num=0,digit=0;
    char str[100];
    double sum=0;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%s",str);
        l=strlen(str);
        k=0;
        t=0;
        p=0;
        for(j=0;j<l;j++)
        {
            if(j==0)
            {
                if(str[j]=='-'||str[j]=='+')
                {
                    k++;
                }
                else if(str[j]=='.'||(str[j]>='0'&&str[j]<='9'))
                {
                    k++;
                    if(str[j]=='.')
                        {
                            p++;
                            for(x=j;x<l;x++)
                            {
                                if(str[x]>='0'&&str[x]<='9')
                                {
                                    t++;
                                    digit++;
                                }
                            }
                            break;
                        }
                        else
                        {
                            digit++;
                        }
                }
            }
            else
            {
                if(str[j]>='0'&&str[j]<='9')
                {
                    k++;
                    digit++;
                }
                else if(str[j]=='.')
                {
                    p++;
                    k++;
                    for(x=j;x<l;x++)
                            {
                                if(str[x]>='0'&&str[x]<='9')
                                {
                                    t++;
                                    digit++;
                                }
                            }
                            break;
                }
            }
        }
        if(p<=1&&k+t==l&&digit!=0)
        {
            double tmp=atof(str);
            if(tmp>=-1000&&tmp<=1000&&t<=2)
            {
                sum=sum+tmp;
                num++;
            }
            else
            {
                printf("ERROR: %s is not a legal number\n",str);
            }
        }
        else
        {
            printf("ERROR: %s is not a legal number\n",str);
        }
    }
    if(num==1)
    printf("The average of 1 number is %.2lf\n",sum);
    else if(num>1)
    printf("The average of %d numbers is %.2lf\n",num,sum/num);
    else
    printf("The average of 0 numbers is Undefined\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值