1140. Look-and-say Sequence (20)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

题目大意:


代码:

#include<stdio.h>
int a[100000],b[100000],l1,l2;
int main()
{
    int i,j,n,m,k,t,num;
    scanf("%d %d",&n,&m);
    a[0]=n;
    l1=1;
    for(i=1;i<m;i++)
    {
        l2=0;
        for(j=0;j<l1;j++)
        {
            if(j==0)
            {
                num=1;
            }
            else
            {
                if(a[j]==a[j-1])
                {
                    num++;
                }
                else
                {
                    b[l2++]=a[j-1];
                    b[l2++]=num;
                    num=1;
                }
            }
        }
        b[l2++]=a[j-1];
        b[l2++]=num;
        l1=l2;
        //printf("%d\n",l1);
        for(j=0;j<l2;j++)
        {
            a[j]=b[j];
        }
    }

    for(i=0;i<l1;i++)
    {
        printf("%d",a[i]);
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值