After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:
ID Score School
where "ID" is a string of 6 characters with the first one representing the test level: "B" stands for the basic level, "A" the advanced level and "T" the top level; "Score" is an integer in [0, 100]; and "School" is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that "ID" is unique for each testee.
Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:
Rank School TWS Ns
where "Rank" is the rank (start from 1) of the institution; "School" is the institution code (all in lower case); "TWS" is the total weighted score which is defined to be the integer part of "ScoreB/1.5 + ScoreA + ScoreT*1.5", where "ScoreX" is the total score of the testees belong to this institution on level X; and "Ns" is the total number of testees who belong to this institution.
The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.
Sample Input:10 A57908 85 Au B57908 54 LanX A37487 60 au T28374 67 CMU T32486 24 hypu A66734 92 cmu B76378 71 AU A47780 45 lanx A72809 100 pku A03274 45 hypuSample Output:
5 1 cmu 192 2 1 au 192 3 3 pku 100 1 4 hypu 81 2 4 lanx 81 2
题目大意:
代码:
#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
#include<algorithm>
#include<math.h>
using namespace std;
struct node
{
string firm;
double sum;
int sum1;
int num;
int Rank;
}person[100001];
map<string,struct node> Map;
bool cmp(struct node a,struct node b)
{
if(a.sum1!=b.sum1)
{
return a.sum1>b.sum1;
}
else if(a.num!=b.num)
{
return a.num<b.num;
}
else
{
return a.firm<b.firm;
}
}
int main()
{
int i,j,n,k,t,l,Rank;
double m;
scanf("%d",&n);
for(i=0;i<n;i++)
{
string g,f;
cin>>g>>m>>f;
for(j=0;j<f.size();j++)
{
if(f[j]>='A'&&f[j]<='Z')
{
f[j]=f[j]+32;
}
}
Map[f].firm=f;
if(g[0]=='A')
{
Map[f].sum+=m;
}
else if(g[0]=='B')
{
Map[f].sum+=(m/1.5);
}
else if(g[0]=='T')
{
Map[f].sum+=(m*1.5);
}
Map[f].num++;
}
map<string,struct node>::iterator it;
l=0;
for(it=Map.begin();it!=Map.end();it++)
{
person[l++]=it->second;
person[l-1].sum1=(int)person[l-1].sum;
}
sort(person,person+l,cmp);
person[0].Rank=1;
for(i=1;i<l;i++)
{
if(person[i].sum1==person[i-1].sum1)
{
person[i].Rank=person[i-1].Rank;
}
else
{
person[i].Rank=i+1;
}
}
printf("%d\n",l);
for(i=0;i<l;i++)
{
printf("%d %s %d %d\n",person[i].Rank,(person[i].firm).c_str(),person[i].sum1,person[i].num);
}
return 0;
}