给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:redlesPayBestPATTopTeePHPereatitAPPT输出样例:
PATestPATestPTetPTePePee
代码:
#include<stdio.h>
char str[100010];
int main()
{
int i,j,n,m,k,P=0,A=0,T=0,e=0,s=0,t=0;
scanf("%s",str);
for(i=0;str[i]!='\0';i++)
{
if(str[i]=='P')
{
P++;
}
else if(str[i]=='A')
{
A++;
}
else if(str[i]=='T')
{
T++;
}
else if(str[i]=='e')
{
e++;
}
else if(str[i]=='s')
{
s++;
}
else if(str[i]=='t')
{
t++;
}
}
while(P||A||T||e||s||t)
{
if(P>0)
{
printf("P");
P--;
}
if(A>0)
{
printf("A");
A--;
}
if(T>0)
{
printf("T");
T--;
}
if(e>0)
{
printf("e");
e--;
}
if(s>0)
{
printf("s");
s--;
}
if(t>0)
{
printf("t");
t--;
}
}
return 0;
}