L2-007. 家庭房产

给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。

输入格式:

输入第一行给出一个正整数N(<=1000),随后N行,每行按下列格式给出一个人的房产:

编号 父 母 k 孩子1 ... 孩子k 房产套数 总面积

其中 编号 是每个人独有的一个4位数的编号; 分别是该编号对应的这个人的父母的编号(如果已经过世,则显示-1);k(0<=k<=5)是该人的子女的个数;孩子i是其子女的编号。

输出格式:

首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:

家庭成员的最小编号 家庭人口数 人均房产套数 人均房产面积

其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出。

输入样例:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
输出样例:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

代码:

#include<stdio.h>  
#include<algorithm>  
using namespace std;  
struct node  
{  
    int id,fatherid,motherid,M_estate,Area;  
    int childid[20];  
}family[1001];  
struct node1  
{  
    int id,person;  
    double M_estate,Area;  
    int flag;  
}answer[10001];  
int F[10001];  
int visited[100001];  
bool cmp(struct node1 a,struct node1 b)  
{  
    if(a.Area!=b.Area)  
        return a.Area>b.Area;  
    else  
        return a.id<b.id;  
}  
int find(int x)  
{  
    while(x!=F[x])  
    {  
        x=F[x];  
    }  
    return x;  
}  
void Union(int x,int y)  
{  
    int fx=find(x);  
    int fy=find(y);  
    if(fx!=fy)  
    {  
        if(fx>fy)  
        {  
            F[fx]=fy;  
        }  
        else  
        {  
           F[fy]=fx;  
        }  
    }  
}  
int main()  
{  
    int i,j,n,m,k,t,cnt=0;  
    for(i=0;i<10000;i++)  
        F[i]=i;  
    scanf("%d",&n);  
    for(i=0;i<n;i++)  
    {  
        scanf("%d %d %d %d",&family[i].id,&family[i].fatherid,&family[i].motherid,&k);  
        visited[family[i].id]=1;  
        if(family[i].fatherid!=-1)  
        {  
            visited[family[i].fatherid]=1;  
            Union(family[i].id,family[i].fatherid);  
        }  
        if(family[i].motherid!=-1)  
        {  
            visited[family[i].motherid]=1;  
            Union(family[i].id,family[i].motherid);  
        }  
        for(j=0;j<k;j++)  
        {  
            scanf("%d",&family[i].childid[j]);  
            visited[family[i].childid[j]]=1;  
            Union(family[i].id,family[i].childid[j]);  
        }  
        scanf("%d %d",&family[i].M_estate,&family[i].Area);  
    }  
    for(i=0;i<n;i++)  
    {  
        int id=find(family[i].id);  
        answer[id].id=id;  
        answer[id].M_estate+=family[i].M_estate;  
        answer[id].Area+=family[i].Area;  
        answer[id].flag=1;  
    }  
    for(i=0;i<10000;i++)  
    {  
        if(visited[i]==1)  
            answer[find(i)].person++;  
        if(answer[i].flag==1)  
            cnt++;  
    }  
    for(i=0;i<10000;i++) {  
        if(answer[i].flag==1) {  
            answer[i].M_estate = (double)(answer[i].M_estate * 1.0 / answer[i].person);  
            answer[i].Area = (double)(answer[i].Area * 1.0 / answer[i].person);  
        }  
    }  
    sort(answer,answer+10000,cmp);  
    printf("%d\n", cnt);  
    for(i=0;i<cnt;i++)  
        printf("%04d %d %.3f %.3f\n",answer[i].id,answer[i].person,answer[i].M_estate,answer[i].Area);  
    return 0;  
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值