树的直径(找出最远村庄距离)

3 篇文章 0 订阅

题目链接:https://vjudge.net/contest/244053#problem/F

Roads in the North

 

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

题目大意就是求最远的两个村庄的距离;村庄个数有10000个,显然用邻接矩阵存图,搜图的时候是要爆的,这次我用的是链式前向星的方式存图,由于是无向图,所以,每两个点要存两次;

 

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;

struct edge{
	int next;
	int y;
	int w;
}vec[20010];
int head[20010];
bool vis[20010];
int cut=1;

void add(int u,int v,int w ){//链式前向星存图 
	vec[cut].y=v;
	vec[cut].w=w;
	vec[cut].next=head[u];
	head[u]=cut++;
}
struct node{
	int x;
	int num;
//	bool operator <(const node &a) const {
//		return num<a.num;
//	}
//不用优先队列好像也行。 
};
int ans=0;
int ex;
void bfs(int bx){
	memset(vis,0,sizeof(vis));
//	priority_queue <node> que;
	queue <node> que; 
	node st1;
	node st2;
	st1.x=bx;
	st1.num=0;
	vis[bx]=1;
	que.push(st1);
	while(!que.empty()){
		//st2=que.top();
		st2=que.front();
		if(st2.num>ans){
			ans=st2.num;
			ex=st2.x;
		}
		que.pop();
		for(int i=head[st2.x]; i!=0; i=vec[i].next){//链式前向星搜图,搜索与此点相连的所有点 ; 
			int bex=vec[i].y;
			if(vis[bex]==0){//如果此点没有搜索过 ; 
				vis[bex]=1;
				st1.x=bex;
				st1.num=st2.num+vec[i].w;//距离增加 ; 
				que.push(st1);//入队列 ; 
			}
		}
	}
}
int main(){
	int x;
	int y;
	int z;
	while(scanf("%d%d%d",&x,&y,&z)!=EOF){
		add(x,y,z);
		add(y,x,z);
	}
	ans=0;//赋初值(这个不能忘,吃过大亏) 
	bfs(1);//第一次bfs找出一个端点; 
	ans=0;
	bfs(ex);//第二次bfs通过第一次bfs找出的端点,找出距离最远值; 
	cout<<ans<<endl;
	return 0;
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值