Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

#include<iostream>
#include<cstdio>
#include<cstring>
#include<iomanip>
#include<cmath>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<string>
#include<sstream>
#include<ctime>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
int mp[103][103];
int dis[103];
bool vis[103];
int n,m;
int a,b,c;
void Dij() {
    dis[1]=0;
    for(int i=1; i<=n; i++) {
        int k,MIN=INF;
        for(int j=1; j<=n; j++) {
            if(dis[j]<MIN&&!vis[j]) {
                MIN=dis[j];
                k=j;
            }
        }
        vis[k]=1;

        for(int j=1;j<=n;j++){
            if(!vis[j]&&dis[j]>dis[k]+mp[k][j]){
                dis[j]=dis[k]+mp[k][j];
            }
        }

    }

}
int main() {
    ios::sync_with_stdio(false);
    while(cin>>n>>m&&(n+m)) {
        memset(mp,INF,sizeof mp);
        memset(dis,INF,sizeof dis);
        memset(vis,0,sizeof vis);
        for(int i=0; i<m; i++) {
            cin>>a>>b>>c;
            if(mp[a][b]>c) {
                mp[a][b]=mp[b][a]=c;
            }
        }
        Dij();
        cout<<dis[n]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值