1.3.6 考试排名 hdu

C++编程考试使用的实时提交系统,具有即时获得成绩排名的特点。它的功能是怎么实现的呢?
我们做好了题目的解答,提交之后,要么“AC”,要么错误,不管怎样错法,总是给你记上一笔,表明你曾经有过一次错误提交,因而当你一旦提交该题“AC”后,就要与你算一算帐了,总共该题错误提交了几回。虽然你在题数上,大步地跃上了一个台阶,但是在耗时上要摊上你共花去的时间。特别是,曾经有过的错误提交,每次都要摊上一定的单位时间分。这样一来,你在做出的题数上,可能领先别人很多,但是,在做出同样题数的人群中,你可能会在耗时上处于排名的劣势。
例如:某次考试一共8题(A,B,C,D,E,F,G,H),每个人做的题都在对应的题号下有个数量标记,负数表示该学生在该题上有过的错误提交次数,但到现在还没有AC,正数表示AC所耗的时间,如果正数a跟上一对括号,里面有个整数b,那就表示该学生提交该题AC了,耗去了时间a,同时,曾经错误提交了b次,因此对于下述输入数据:

若每次错误提交的罚分为20分,则其排名从高到低应该是这样的:
Josephus 5 376
John 4 284
Alice 4 352
Smith 3 167
Bob 2 325
Bush 0 0

Input
输入数据的第一行是考试题数n(1≤n≤12)以及单位罚分数m(10≤m≤20),每行数据描述一个学生的用户名(不多于10个字符的字串)以及对所有n道题的答题现状,其描述采用问题描述中的数量标记的格式,见上面的表格,提交次数总是小于100,AC所耗时间总是小于1000。

Output
将这些学生的考试现状,输出一个实时排名。实时排名显然先按AC题数的多少排,多的在前,再按时间分的多少排,少的在前,如果凑巧前两者都相等,则按名字的字典序排,小的在前。每个学生占一行,输出名字(10个字符宽),做出的题数(2个字符宽,右对齐)和时间分(4个字符宽,右对齐)。名字、题数和时间分相互之间有一个空格。

Sample Input

8 20
Smith -1 -16 8 0 0 120 39 0
John 116 -2 11 0 0 82 55(1) 0
Josephus 72(3) 126 10 -3 0 47 21(2) -2
Bush 0 -1 -8 0 0 0 0 0
Alice -2 67(2) 13 -1 0 133 79(1) -1
Bob 0 0 57(5) 0 0 168 -7 0

Sample Output

Josephus 5 376
John 4 284
Alice 4 352
Smith 3 167
Bob 2 325
Bush 0 0

#include<iostream>
#include<cstdio>
#include<cstring>
#include<iomanip>
#include<cmath>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<string>
#include<sstream>
#include<ctime>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
int n,m;
struct info {
    string name;
    int time,solve;
    info() {
        time=0,solve=0;
    }
};
vector<info>peos;
bool cmp(info a,info b) {
    if(a.solve!=b.solve) {
        return a.solve>b.solve;
    } else if(a.time!=b.time) {
        return a.time<b.time;
    } else {
        return a.name<b.name;
    }
}
int main() {
    ios::sync_with_stdio(false);
   //freopen("in.txt","r",stdin);
    while(cin>>n>>m&&n) {
        peos.clear();
        string nam,scor;
        while(cin>>nam) {
            info per;
            per.name=nam;

            for(int i=0; i<n; i++) {
                bool flag=0;
                cin>>scor;
                if(scor[0]=='-'||scor=="0") {
                    continue;
                } else {
                    per.solve++;
                    int sum=0;
                    for(int i=0; i<scor.length(); i++) {
                        if(scor[i]>='0'&&scor[i]<='9') {
                            sum=sum*10+scor[i]-'0';
                        } else if(scor[i]=='(') {
                            per.time+=sum;
                            sum=0;
                        } else if(scor[i]==')') {
                            per.time+=sum*m;
                            sum=0;
                        }
                    }
                    per.time+=sum;
                }
            }

            peos.push_back(per);

        }
        sort(peos.begin(),peos.end(),cmp);
        for(int i=0; i<peos.size(); i++) {
            cout<<std::left<<setw(10)<<peos[i].name<<" ";
            cout<<std::right<<setw(2)<<peos[i].solve<<" ";
            cout<<std::right<<setw(4)<<peos[i].time;
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值