Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
Sample Output
3 5Huge input, scanf is recommended.HintHint
WA点:数组要开得大一点!!!
<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int father[111];
int find(int x)
{
int r=x;
while(father[r]!=r) r=father[r];
int i=x,j;
while(i!=r) {
j=father[i];
father[i]=r;
i=j;
}
return r;
}
struct node
{
int u;
int v;
int w;
} a[5555];
bool cmp(node x,node y)
{
if(x.w<y.w) return true ;
return false;
}
int main()
{
int n,m,ans;
int i,j;
while(scanf("%d",&n)==1 && n) {
m=n*(n-1)/2;
for(i=1;i<=n;i++) father[i]=i;
for(i=1;i<=m;i++) {
scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].w);
}
sort(a+1,a+1+m,cmp);
ans=0;
for(i=1;i<=m;i++) {
int fx=find(a[i].u);
int fy=find(a[i].v);
if(fx!=fy) {
ans+=a[i].w;
father[fx]=fy;
}
}
printf("%d\n",ans);
}
return 0;
}</span>