HDU 5475 An easy problem (暴力||线段树_好题 )

Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 




昨天的上海网络赛题,,一开始用大数做,被带到坑里去了。。

线段树裸题,,或者可以直接暴力。一开始以为暴力会超时,,没想到就过了。。。



效率差了将近一倍。。


暴力解法:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e5+100;
__int64 a[maxn];

int main()
{
	int t,n,mod,x,i,j;
	__int64 temp,temp2,y;
	scanf("%d",&t);
	for(int _=1;_<=t;_++) {
		scanf("%d%d",&n,&mod);
		temp=1;
		for(i=1;i<=n;i++) {
			scanf("%d%I64d",&x,&y);
			if(i==1) printf("Case #%d:\n",_);
			if(x==1) {
				a[i]=y;
				temp=temp*y%mod;
				printf("%I64d\n",temp);
			}
			else {
				temp=1;
				a[y]=1;
				a[i]=1;
				for(j=1;j<i;j++) {
					 temp= temp*a[j]%mod;
				}
				printf("%I64d\n",temp);
			}
		}
	}
	return 0;
}








线段树:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include  <iostream>
using namespace std;
typedef long long ll;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=155555;
ll sum[maxn*4+4];
int add;
int a[maxn];
int L,R;
int MOD;
int p;

void pushup(int rt){
    sum[rt]=sum[rt<<1]*sum[rt<<1|1]%MOD;
}

void build(int l,int r,int rt){
    if(l==r){
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int l,int r,int rt){
    if(l==r){
        sum[rt]=add;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m)
        update(lson);
    else
        update(rson);
    pushup(rt);
}

ll query(int l,int r,int rt){
    ll ret=1;
    if(L<=l&&R>=r)
        return sum[rt];
    int m=(l+r)>>1;
    if(L<=m)
        ret*=query(lson)%MOD;
    if(R>m)
        ret*=query(rson)%MOD;
    return ret%MOD;
}

int main()
{
    int n,m;
    int op,u,q;
    int t;
    scanf("%d",&t);
    for(int case1=1;case1<=t;case1++){
        printf("Case #%d:\n",case1);
        scanf("%d%d",&q,&MOD);
        build(1,q,1);
        for(int i=1;i<=q;i++){
            scanf("%d%d",&op,&u);
            if(op==1){
                p=i;
                add=u;
                update(1,q,1);
                L=1;
                R=i;
                printf("%I64d\n",query(1,q,1)%MOD);
            }
            else{
                p=u;
                add=1;
                update(1,q,1);
                L=1;
                R=i;
                printf("%I64d\n",query(1,q,1)%MOD);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值