HDU 5475 La Vie en rose(暴力 2016 Multi-University Training Contest 2 )



传送门
Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2…pm. So, he wants to generate as many as possible pattern strings from p using the following method:

  1. select some indices i1,i2,…,ik such that 1≤i1< i2<…< ik<|p| and |ij−ij+1|>1 for all 1≤j< k.
  2. swap pij and pij+1 for all 1≤j≤k.

Now, for a given a string s=s1s2…sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n≤105,1≤m≤min{5000,n}) – the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.

Output
For each test case, output a binary string of length n. The i-th character is “1” if and only if the substring sisi+1…si+m−1 is one of the generated patterns.

Sample Input
3
4 1
abac
a
4 2
aaaa
aa
9 3
abcbacacb
abc

Sample Output
1010
1110
100100100

题目大意: 

模式匹配,可以交换一次相邻字符。
 

说句实话,这道题的标程是dp,有的人用暴力过了,这里我用的是kmp优化写的,速度3588MS

#include<stdio.h>
 #include<string>
 #include<cstring>
 #include<iostream>
 using namespace std;
 int f[100000];
 void get_next(string a)
 {
     int i=0;f[0]=-1;int j=-1;
     while(i<a.length()-1)
     {
         if(j==-1||a.c_str()[i]==a.c_str()[j])
         {
             ++i;
             ++j;
             f[i]=j;
         }
         else
             j=f[j];
     }
 }
 int kmp(string a,string b,int pos)
 {
     int i=pos;int j=0;
     int l1,l2;
     l1=a.length();
     l2=b.length();
     while(i<l1&&j<l2)
     {
         bool fa=0;
         if(j==-1||a.c_str()[i]==b.c_str()[j])
         {
             i++;j++;
         }
         else if(fa==0&&l1!=i&&l2!=j)
         {
             fa=1;
             if(a.c_str()[i+1]==b.c_str()[j]&&a.c_str()[i]==b.c_str()[j+1])
             {
                 i+=2;
                 j+=2;
             }
             else
                 return -1;
         }
         else j=f[j];
     }
     if(j>=b.length())return i-b.length();
     return -1;
 }
 int main()
 {
     string a;
     string b;
     int t;
     scanf("%d",&t);
     while(t--)
     {
         int c,d;
         scanf("%d %d",&c,&d);
         cin>>a>>b;
         get_next(a);
         int temp=0;
        for(int i=0;i<c;i++)
             if(kmp(a,b,i)!=-1)
                printf("1");
             else printf("0");
        printf("\n");
     }
     return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值