uva 437 The Tower of Babylon (DAG_变形 ,dp)

22 篇文章 0 订阅
16 篇文章 0 订阅

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

意为输入若干种立方体(每种若干个),然后将立方体堆成一个塔,要求接触的两个面下底面的长宽分别严格大于上底面,求塔的最大高度。

将每种立方体的各种摆放形式均视为不同的立方体,并存起来。再将所有立方体按照下底面的面积从小到大排序(因为在塔上面的立方体的底面积一定比下面的小),然后只需求该序列的最大上升子序列的长度即可。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct node
{
	int x;
	int y;
	int z;
	void f(int a,int b,int c) {
		x=a;y=b;z=c;
	}
} a[1000];

bool cmp(node t1,node t2)
{
	if(t1.x*t1.y>t2.x*t2.y) return true;
	return false;
}

int dp[1000];

int main()
{
	int n,i,j,x,y,z,m,ans,num,t;
	num=0;
	while(cin>>n && n) {
		m=0;
		ans=0;
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++) {
			cin>>x>>y>>z;
			a[++m].f(x,y,z);
			a[++m].f(x,z,y);
			a[++m].f(y,x,z);
			a[++m].f(y,z,x);
			a[++m].f(z,x,y);
			a[++m].f(z,y,x);
		}
		sort(a+1,a+1+m,cmp);
		for(i=1;i<=m;i++) {
			dp[i]=a[i].z;
			for(j=1;j<i;j++) {
				if(a[j].x>a[i].x && a[j].y>a[i].y)
				dp[i]=max(dp[i],dp[j]+a[i].z);
			}
			ans=max(dp[i],ans);
		}
		printf("Case %d: maximum height = %d\n",++num,ans);
	}
	return 0;
}





















  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值